Algorithme du Jaken

rockAlgo Jaken

La version complète du jeu est disponible ici :

http://www.angelfire.com/blog/gya/Jaken.7z 

Vous pouvez également consulter le code source sur Csharpfr.com

http://www.csharpfr.com/codes/JEU-PIERRE-FEUILLE-CISEAUX-JANKENPON_34692.aspx 

Variables

scor, scor2, choix : entierstexte, choix2 : caractères
DEBUT

Afficher "Jeu de Jaken"
Afficher "Licence publique générale GNU"   

scor <- 0
scor2 <- 0
choix <- 0
choix2 <- "pierre"

Répéter
    Afficher " "
    Répéter
        Afficher "pierre, papier ou ciseau?"
        Saisir texte
    Jusqu'à texte="pierre" ou texte="papier" ou texte="ciseau"

si texte = "pierre" alors
        choix <- 0
    finsi
    si texte = "papier" alors
        choix <- 1
    finsi
    si texte = "ciseau" alors
        choix <- 2
    finsi

Afficher " "
    Afficher "joueur1: ", texte       

nb <- aléatoire(2)

si nb = 0 alors
        choix2 <- "pierre"
    finsi
    si nb = 1 alors
        choix2 <- "papier"
    finsi
    si nb = 2 alors
        choix2 <- "ciseau"
    finsi   

Afficher "joueur2: ", choix2
    Afficher " "

si choix=0 et nb=0 alors
        Afficher "Partie Nulle."
    sinon
        si choix=0 et nb=1 alors
            Afficher "Le papier recouvre la pierre."
            scor2 <- scor2 + 1
        sinon
            si choix=0 et nb=2 alors
                Afficher "La pierre casse les ciseaux."
                scor <- scor + 1
            finsi
        finsi
    finsi

si choix=1 et nb=0 alors
        Afficher "Le papier enveloppe la pierre."
        scor <- scor + 1
    sinon
        si choix=1 et nb=1 alors
            Afficher "Partie Nulle."
        sinon
            si choix=1 et nb=2 alors
                Afficher "Le ciseau coupe le papier."
                scor2 <- scor2 + 1
            finsi
        finsi
    finsi

si choix=2 et nb=0 alors
        Afficher "La pierre casse le ciseau."
        scor2 <- scor2 + 1
    sinon
        si choix=2 et nb=1 alors
            Afficher "Le ciseau coupe le papier."
            scor <- scor + 1
        sinon
            si choix=2 et nb=2 alors
                Afficher "Partie Nulle."
            finsi
        finsi
    finsi

Afficher " "
    Afficher "Les scores sont :"
    Afficher "Joueur1 : ", scor
    Afficher "Joueur2 : ", scor2
    Afficher " "

Répéter
        Afficher "Encore une partie?(O/N)"
        Saisir texte
        texte <- agrandir(texte)
    Jusqu'à texte="N" ou texte="O"

jusqu'à texte="N"

FIN

WikiMonnaie

WIKIMONAIE.png"La wikimonnaie est un système de crédit mutuel utilisé par les Wikipédiens anglophones. Son principe est de créer une économie où les personnes peuvent proposer un travail sur Wikipédia contre de la wikimonnaie ou remplir une tâche proposée pour en gagner.

Tout contributeur régulier (actif depuis un mois et ayant au moins 200 éditions à son actif) peut ouvrir un compte sur cette page et se voit offrir 20 unités de wikimonnaie (W) indivisibles. Cette monnaie virtuelle pourra alors servir à s'échanger des services.

Les comptes de chacun sont publics et maintenus dans la section WikiBanque de cette page. Pour transférer la wikimonnaie d'un compte à un autre, il suffit d'éditer les montants des comptes. Seul le débiteur transfère les W de son compte vers celui qui a répondu à son offre.

Pourquoi essayer de récolter de la wikimonnaie ? Tout simplement, cela vous permettra d'investir dans des domaines qui vous tiennent à cœur. Le temps que vous investissez pour d'autres vous permettra aussi de demander du temps à d'autres. Rien ne vous empêche de vous regrouper pour proposer une offre alléchante ! Souvenez vous que la WikiMonnaie n'est qu'une monnaie virtuelle et ne doit pas être prise trop au sérieux !"

Texte disponible sous GNU Free Documentation License.

J'ai crée un programme qui reprend cette idée. Il est consultable ici :

http://www.csharpfr.com/codes/WIKIMONNAIE-MONNAIE-LIBRE_35790.aspx

Pivot de Gauss

"En mathématiques, l'élimination de Gauss ou l'élimination de Gauss-Jordan, nommé en hommmage à Carl Friedrich Gauss et Wilhelm Jordan est un algorithme de l'algèbre linéaire pour déterminer les solutions d'un système d'équations linéaires, pour déterminer le rang d'une matrice ou pour calculer l'inverse d'une matrice carrée inversible. Lorsqu'on applique l'élimination de Gauss sur une matrice, on obtient sa forme échelonnée réduite." d'après wikipédia (http://fr.wikipedia.org/wiki/Élimination de Gauss-Jordan). Je n'aurais pas mieux dit 😉

L'application que j'ai faite moi même et son code source sont sur :

http://www.csharpfr.com/codes/METHODE-ELIMINATION-GAUSS-JORDAN-PIVOT-GAUSS-POUR-SYSTEMES_35153.aspx

Du bon usage de la piraterie : culture libre, sciences ouvertes.

piraterieFlorent Latrive, journaliste à Libération, s’est rendu célèbre dans le milieu des logiciels libres grâce à l’ouvrage Du bon usage de la piraterie : culture libre, sciences ouvertes. Il est aussi coresponsable et rédacteur régulier de la liste de diffusion [escape_l] et du site Biblio du Libre sur « la propriété intellectuelle dans tous ses débats ».

http://justine.miso.entierement.nu/IMG/mp3/lbienpublic_bienprive.mp3

http://www.angelfire.com/musicals/incipitblog/Des_monopoles_troues.mp3

Anarchy Online

Anarchy Online Girl Gun Wallpaper

Anarchy Online est un jeu en ligne massivement multi-joueurs sorti mondialement en juin 2001 par la société Funcom.

C’est le premier jeu de ce type à être basé sur un univers qui n’est pas médiéval fantastique. L’action est située dans trente mille ans sur une planète fictive nommée Rubi-Ka. Pour remplacer la magie, les capacités inhabituelles des personnages sont rendues possibles grâce à la nanotechnologie.

L’histoire à laquelle participent les joueurs est basée sur une énorme société baptisée Omni-Tek ayant reçu l’exclusivité pour l’exploitation d’une ressource naturelle nommée notum. Cette substance est nécessaire au développement des nanotechnologies.

Quelque temps après être arrivés sur la planète, un bon nombre de colons, s’estimant mal traités, se rebellent contre la société. Ils organisent alors un marché noir de notum volé avec une société concurrente. Ils commencent à exclure le personel d’Omni-Tek des cités les plus éloignées et une guerre civile débute entre Omni-Tek, les Clans et une troisième faction neutre.

Malgré les nombreux bugs et la mauvaise presse au lancement, les serveurs comptaient 35 000 joueurs avant le 4 juillet 2001. Depuis le 28 septembre 2001, le jeu est disponible dans le commerce en France; ce délai a permis de résoudre les bugs les plus gênants et la version est suffisamment stable. Le jeu a d’ailleurs remporté le titre de « Best Multiplayer Game of Show » à l’ECTS en septembre 2001.

Depuis, des extensions du jeu ont été publiées :

  • Notum Wars a d’abord vu le jour, les organisations (équivalentes aux guildes d’autres MMORPG) peuvent contrôler les terres de Rubi-Ka pour exploiter le notum pour leur compte et ainsi améliorer les caractéristiques de leurs personnages. Cela se fait par l’intermédiaire de contrôleurs et de tours qui attaquent directement les ennemis.
  • Ensuite Shadowlands qui introduit une nouvelle race de personnage : les shadow. On trouve aussi des nouveaux terrains de jeux (les Shadowlands) et notamment la nouvelle cité de Jobe qui héberge des scientifiques d’Omni-Tek ayant préféré la neutralité.
  • La dernière des extensions a avoir été publiée est Alien Invasion. Comme son nom le laisse entendre, on trouve des aliens et toute une technologie d’objets, d’armes et d’armures associée. Les organisations peuvent désormais bâtir des villes entières pour améliorer leurs revenus.
Publié dans Jeux vidéo. Étiquettes : , , . Leave a Comment »

BLAME! Tsutomu NIHEI

BLAME! (c’est une onomatopée) est un manga cyberpunk en dix volumes de Tsutomu Nihei, ancien étudiant en architecture qui a finalement préféré se tourner vers le manga, paru en français aux éditions Glénat. Six OAVs, disponibles uniquement en DVD au Japon, on été developpés en parrallèle, reprenant certaines scènes du manga, dans un style très experimental, avec peu de dialogues et une bande-son constituée essentiellement de bruitages.

Une suite, nommée Blame NSE est actuellement en cours de réalisation, de plus, l’auteur a dévoilé participer à d’autres projets comme « Biomega » qui se déroulent dans le même genre d’univers que Blame! Un artbook « Blame! and so on » est aussi actuellement disponible, pour ainsi mieux comprendre et apprécier l’art particulier de Nihei.

L’histoire

Killy est un enquêteur à la recherche d’un terminal génétique et d’un porteur de gènes sains. Il travaille indirectement pour le compte d’un certain bureau gouvernemental, instance de la résosphère. Au cours de sa quête, il rencontre Shibo, une scientifique qui se propose de l’accompagner. Shibo et Killy doivent faire face à des silicates, ainsi qu’à des sauvegardes, étranges créatures poursuivant un but bien précis dans une guerre technologique où il n’y a ni pitié ni prisonniers.

L’univers

Le premier texte que l’on peut lire en ouvrant le premier tome est peut-être dans le futur, peut-être sur terre. Le monde de BLAME! est immense, il est une fresque abstraite et angoissante d’un futur décrit par les auteurs les plus pessimistes de la science fiction, où il n’y a ni verdure ni bonheur. Celui-ci s’étale sur des milliers d’étages, faisant parfois eux-même des milliers de kilomètres de haut ! L’ambiance globale est assez sombre, morose et post-apocalyptique.

Le manga Noise, du même auteur et même éditeur, permet d’éclaircir certains points obscurs de cet univers. Il contient également l’histoire pilote de BLAME!

Personnages principaux

Killy
c’est un enquêteur à la recherche d’un terminal génétique. Il est armé d’un redoutable émetteur de positrons. Il apparaît au début comme un personnage très froid, mais évolue au cours de l’histoire pour s’humaniser sensiblement.
Shibo
Elle apparaît dans le tome 2 . Jusque là, les personnages secondaires apparaissaient puis disparaissaient très vite, soulignant le côté dangereux et instable de cet univers, où rien n’est sûr. Le lecteur s’attache donc assez vite à elle, d’autant plus qu’elle fait montre d’une sensibilité qui manquait à Killy, obnubilé par sa quête de terminaux génétiques. C’est une scientifique en chef, renégat d’une société de pilleurs de corps.

Les court métrage en 3D

http://www.youtube.com/watch?v=nHs4Lme-NCY

http://www.youtube.com/watch?v=jt4pRDHUWkk

Texte disponible sous GNU Free Documentation License.

GNOME

GNOME, acronyme de GNU Network Object Model Environment, est un environnement graphique convivial dont l’objectif est de rendre accessible l’utilisation du système d’exploitation GNU au plus grand nombre ; cette interface est actuellement populaire sur les systèmes GNU/Linux et fonctionne également sur la plupart des systèmes de type UNIX.