Recherche dichotomique


//déclarations
entier : début, milieu, fin, val
Tnb [0..100] : Tableau d’entier

//initialisation
début <- 0
fin <- 100

//Question
Répéter
Afficher « Valeur recherchée? »
Saisir val
Jusqu’à début<=val et val<=fin

//Boucle de recherche
Répéter

//Calcul du milieu
milieu = arrondiàl’unité((début+fin)/2)

//Conditions et affectations
Si val > Tnb[milieu] alors

début <- milieu + 1

Sinon

Si val=Tnb[milieu] alors

début <- milieu
fin <- milieu

Sinon

fin <- milieu – 1

Finsi

Finsi

jusqu’à début=fin

//Affichage du résultat
Afficher « La valeur est « , val

Texte disponible sous GNU Free Documentation License

Laisser un commentaire

Choisissez une méthode de connexion pour poster votre commentaire:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

%d blogueurs aiment cette page :