Algorithme de la Pile (informatique)


Procédure PUSH (objet : o) //ajouter un élément sur la pile

Début
Si sommet < max Alors
Tpile[sommet++] <- o
Sinon
Afficher « Pile pleine »
Fin Si
Fin

Fonction POP () : objet //enlever un élément de la pile et le renvoyer
objet : o
Début
Si non vide() Alors
0 <- Tpile[sommet]
Sommet <- Sommet – 1
Sinon
Afficher « Pile vide »
Finsi
Retourner o
Fin

Publié dans Informatique, Wikipédia. Étiquettes : , , . Leave a Comment »

Laisser un commentaire

Choisissez une méthode de connexion pour poster votre commentaire:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

%d blogueurs aiment cette page :